No new window is opening for scraping

Hello, I am encountering an issue an cannot scrap any sitemap from some day.

When I am trying to launch a new scraping, a new window is opening going to the Chrome extension page, then it loads for some minutes and tells me that scraping will start from a new window.

But it actually does not open a new window and never starts...

I have tried to delete and install again the extension but does not work. I downloaded latest version of Chrome also but does not work.

Any idea ?

PS : you can see the screenshots and the errors I get

@nathanguillaumin Hello, could you, please, provide the sitemap you are referring to? Have you tried running the scrape within the incognito window by disabling any other extensions that might interfere with the scraper?

Yes I tried it and it does not work.

Here is the sitemap (an example that you provided and that I tried - it did not work neither with none of my sitemaps- :

{"_id":"Renta_Inmuebles","startUrl":[""],"selectors":[{"id":"Pages","paginationType":"linkFromHref","parentSelectors":["_root","Pages"],"selector":"a[data-qa=\"PAGING_NEXT\"]","type":"SelectorPagination"},{"id":"Anuncios","multiple":true,"parentSelectors":["Pages"],"selector":"div[data-to-posting]","type":"SelectorElement"},{"id":"Precio","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"","type":"SelectorText"},{"id":"Mantenimiento","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"","type":"SelectorText"},{"id":"Titulo","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"a","type":"SelectorText"},{"id":"Delegación_Municipio","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"","type":"SelectorText"},{"id":"tamaño total","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"span:nth-of-type(1) span","type":"SelectorText"},{"id":"tamaño construido","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"span:nth-of-type(2) span","type":"SelectorText"},{"id":"Recamaras","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"span:nth-of-type(3) span","type":"SelectorText"},{"id":"baños","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"span:nth-of-type(4) span","type":"SelectorText"},{"id":"cajones","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"span:nth-of-type(5) span","type":"SelectorText"},{"id":"Descripción","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"","type":"SelectorText"},{"id":"tipo de anuncio","multiple":false,"parentSelectors":["Anuncios"],"regex":"","selector":"","type":"SelectorText"}]}

Here a new screenshot with errors :

@nathanguillaumin Hi, could you, please, share a recording that indicates this issue?

Hi Viesturs and thanks for your answer. What do you mean by a recording ? Like a video Loom ?

@nathanguillaumin Hi, yes a video recording via Loom would suffice.

Please, be sure to test this for the Mozilla FF extension version as well: Web Scraper for Mozilla FF

Thanks. Here is the video (you can put it in x1.5 or x2), you will see that a new window is opening after 1 minute of loading but then nothing happens : Loom | Free Screen & Video Recording Software | Loom

Thank you for your help.

@nathanguillaumin Hi. Thanks for providing the video recording. As it appears you have enabled the Toggle device toolbar option within the developer tools and there are other extensions you are using.

Could you, please, test this within the incognito mode and send the errors that are being returned within the scraper pop-up window? To inspect the errors - open the developer tools within the scraper pop-up window and navigate to the 'Console' tab.


I removed and install again the extension, did it in incognito mode and it appears to work now.

Not sure though of what caused the trouble.