Links not being report in scrape

Describe the problem.
This sitemap appears to run ok but is not extracting all the links. If I use the data preview I see some links but not all of the 25 per page! Any help appreciated.

Url: Find Commercial Properties For Sale in London | Rightmove

Sitemap:
{"_id":"rm_com_search","startUrl":["Find Commercial Properties For Sale in London | Rightmove span","type":"SelectorText"},{"delay":0,"id":"agent","multiple":false,"parentSelectors":["wrapper"],"regex":"","selector":"div.propertyCard-branchSummary","type":"SelectorText"},{"delay":0,"id":"link","multiple":false,"parentSelectors":["wrapper"],"selector":"a.swipe-wrap","type":"SelectorLink"}]}

@pjs6557 Hi, are you trying to scrape the links that are leading to the property page?

If so - you should be able to do that with the following sitemap:

{"_id":"rightmove-co-uk","startUrl":["https://www.rightmove.co.uk/commercial-property-for-sale/find.html?searchType=SALE&locationIdentifier=REGION%5E87490&insId=1&radius=40.0&displayPropertyType=commercial&businessForSale=&minBedrooms=&maxBedrooms=&minPrice=&maxPrice=&areaSizeUnit=sqft&minSize=&maxSize=&partBuyPartRent=&maxDaysSinceAdded=&includeSSTC=true&_includeSSTC=on&sortByPriceDescending=&primaryDisplayPropertyType=&secondaryDisplayPropertyType=&oldDisplayPropertyType=&oldPrimaryDisplayPropertyType=&newHome=&auction=false"],"selectors":[{"delay":0,"id":"wrapper","multiple":true,"parentSelectors":["_root"],"selector":"div.propertyCard-wrapper:has(a)","type":"SelectorElement"},{"delay":0,"id":"link","multiple":false,"parentSelectors":["wrapper"],"selector":"a.property-card-updates","type":"SelectorLink"}]}

Many thanks viesturs, works perfectly now.