Data incorrectly read by MS Excel

Microsoft Excel by default incorrectly reads CSV files with escaped characters.

Here is what you cat try to work around this:

  1. Instead of opening the csv file import it with "load data from text/csv" function. This works better than opening the file directly. Instructions below. Note older MS Excel versions might parse the file incorrectly.
  2. Use Libre Office. Opening CSV file should work without any configuration
  3. If you are using a Mac try using Numbers

How to open a CSV file with MS Excel (office 365):

  1. Start with an empty file
  2. Go to Data tab
  3. Choose From Text/CSV
    excel - data from text csv
  4. Open CSV file
  5. Set up import settings - UTF-8 encoding, Comma delimiter, Do not detect data types
  6. Load data
1 Like